Swarm:Platforms

From Swarm
Jump to: navigation, search

This page has archived information on running Swarm on more exotic platforms.

For information on running Swarm on Linux, Windows, and Macintosh:</br> go to the stable release page.


HP/UX

Swarm 2.0 is known to run on HPUX 9, 10, and 11. Java users of Kaffe will need this [27]libltdl patch. Also, to avoid a linker bug, build gcc-2.95 with this [28]compiler patch to gcc/objc/objc-act.c


IRIX

We have reports from some successful users of Swarm on SGIs in the following configurations:

  • SGI Origin 200, IRIX 6.4, GCC 2.7.2.2 w/old_ld configured for IRIX 5.3
  • IRIX 5.3, GCC 2.7.2.1
  • IRIX 6.4 GCC 2.8
  • IRIX 6.5 GCC 2.95.1

Note that IRIX users need to install libffi, and configure Swarm with the --with-ffidir option.